Data Processing latency
Incident Report for Amplitude
Resolved
From 7:02 AM till 12:40 PM PDT, March 15th 2024, all our customers using our US data center have experienced a data processing and event streaming latency of up to 91 minutes. This was due to some malformed data sent by some customers. All our components are now caught up and work normally. We have not had any data loss during this incident.
Posted Mar 15, 2024 - 12:50 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 15, 2024 - 10:39 PDT
Monitoring
We have identified the root cause and the data processing latency is recovering. Next update will be before 11:30 AM PT
Posted Mar 15, 2024 - 09:43 PDT
Investigating
From 7:02 AM March 15th 2024, all our customers are experiencing a growing latency of up to 60 minutes in our data processing component. We do not expect any data loss. We are investigating the issue and will provide an update before 10 AM PT
Posted Mar 15, 2024 - 08:27 PDT
This incident affected: Data (Data Processing, Event Streaming).