As of 3:10 PM PT, we have fully recovered and all systems are operating normally.
Posted Feb 27, 2026 - 15:47 PST
Identified
Since 2026-02-27 1:14 PT, some Amplitude users may have experienced issues while loading charts/dashboards. Our team is actively investigating the source of the issue and working to deploy a fix. New data ingested recently might be delayed and not show up in results by up to 30 mins. We expect no data loss. No customer action is needed at this time.
We will provide the next update by 2026-02-27 3:00 PM PT.
Posted Feb 27, 2026 - 14:22 PST
This incident affected: Analytics (Web Reporting).