Warehouse import and export delay

Incident Report for Amplitude

Resolved

We have successfully mitigated the root cause of the internal latency affecting Data Warehouse Import and Cloud Storage Import. Data processing and export delays have returned to normal levels, with all systems operating as normal. We will continue to monitor to ensure stability.
Posted Jun 21, 2025 - 00:12 PDT

Monitoring

We are still monitoring the recovery. Delays are under 1 hour currently.
Posted Jun 20, 2025 - 22:59 PDT

Identified

We are experiencing internal latency when importing customers' data since 2025-06-20 6:30 pm UTC. For customers using Data Warehouse Import and Cloud Storage Import, export time to Data Warehouse and Cloud Storage integrated services is elevated (up to 4 hours delay). The root cause is identified and the remediation is applied. We will keep monitoring the recovery.
Posted Jun 20, 2025 - 22:32 PDT
This incident affected: Data (Data Processing, Data Export).