This incident has been resolved. We don't expect any data loss, and no action is required on your end.
Posted Sep 24, 2026 - 14:22 PDT
Update
We are continuing to monitor for any further issues. We will provide another update in 30 minutes.
Posted Sep 24, 2026 - 13:43 PDT
Monitoring
A fix has been implemented and we are monitoring the results. We will provide another update in 30 minutes.
Posted Sep 24, 2026 - 13:13 PDT
Identified
The issue has been identified and a fix is being implemented. We will provide another update in 30 minutes.
Posted Sep 24, 2026 - 12:58 PDT
Investigating
Since 2026-09-24 09:30 PT (17:30 UTC), Amplitude has been experiencing a delay in Data Export processing due to a lagging data partition. Realtime data processing and Amplitude charts and dashboards are not impacted. No data is being lost, and delayed exports will complete once the underlying issue is resolved. No customer action is needed at this time.