AWS Outage: Amplitude User Interface and Data Ingestion Unaffected

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 18:48 PDT

Monitoring

Amplitude's user interface and data ingestion were not impacted by the recent AWS outage. However, your downstream destinations may have been impacted and we recommend checking with your vendor's status page to confirm impact.
Posted Oct 20, 2025 - 11:57 PDT