The lags are fully resolved now. Appreciate your patience!
Posted Jul 23, 2025 - 17:00 PDT
Update
Our data processing systems are fully recovered.
Posted Jul 23, 2025 - 16:29 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 23, 2025 - 14:09 PDT
Update
Data process has full caught up. Streaming and Export are still catching up.
Posted Jul 23, 2025 - 13:13 PDT
Monitoring
The root cause has been resolved. We’re actively monitoring and tuning data processing to catch up on the lag.
Posted Jul 23, 2025 - 10:48 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 23, 2025 - 08:53 PDT
Investigating
Our data processing systems are delayed for up to 40 minutes so far. This incident started at 7:40am PDT.
Current status: a) Our ingestion systems are working as expected and no data is lost. Our processing systems are not processing newly ingested data. c) Impacted customers will see delayed metrics for the last 40 minutes.
We are investigating the issue and will post an update in an hour or earlier if we identify the issue.
Posted Jul 23, 2025 - 08:24 PDT
This incident affected: Data (Data Processing, Event Streaming, Data Export).