Event streaming has largely recovered. Fewer than 1% of events are still experiencing delays of over one hour. We’ll provide another update once latency has returned to normal for all data.
Posted Apr 15, 2026 - 17:21 PDT
Update
Event streaming has largely recovered. Fewer than 1% of events are still experiencing delays of over 30 minutes. We’ll provide another update once latency has returned to normal for all data.
Posted Apr 15, 2026 - 17:20 PDT
Monitoring
Since 2026-04-15 12:20 PT (19:20 UTC), Amplitude has been experiencing high latency in Event Streaming.
Current status: a) Our ingestion and data processing systems are working as expected and no data is lost. b) All of our customers are impacted. c) Impacted customers will see delayed event data in 3rd party Event Streaming destinations for the last 3 hrs.
Our team has identified the issue and is actively working on a resolution. There is no data loss, and data will still be sent to downstream destinations. No customer action is needed at this time.