Data Export Lag

Incident Report for Amplitude

Resolved

All warehouse exports have caught up since 2:00PM PDT. This incident has been resolved.

The issue was caused by an unusually large export request from one customer, which created a bottleneck in our data transformation jobs. This led to delays across both the Export API and Data Warehouse Exports. While the system has since been scaled to resolve the lag, we're working on improving monitoring and safeguards to better handle similar situations in the future.
Posted May 23, 2025 - 15:04 PDT

Update

Our Export API lag has fully recovered. We’re continuing to monitor the Data Warehouse Exports. We’ll provide another update once those jobs have fully recovered as well.
Posted May 23, 2025 - 12:27 PDT

Monitoring

Starting at 1:40 AM PDT, our data export processing began experiencing significant lag. This has impacted both the Export API and Data Warehouse Exports, with delays potentially reaching up to 10 hours. We've identified the underlying bottleneck and have scaled up the affected system. As a result, we expect the lag to decrease significantly within the next 30 minutes. Our team is closely monitoring the recovery and will continue to provide updates as the situation improves. No data is lost.
Posted May 23, 2025 - 11:58 PDT
This incident affected: Data (Data Export).