We have identified the issue to be related to a misconfigured configuration in our feature flags. We have reverted the change as of 1PM PT and we should be back to normal now. We'll still monitor this for a bit before resolving the issue.
Posted Apr 23, 2026 - 13:02 PDT
Investigating
Amplitude web application in US is not accessible. The issue started around 12:20 PST we're still investigating the root cause. Amplitude in EU is working as expected.
a) Our ingestion systems were working as expected and we were not losing any data. b) Impacted customers might experience errors when loading Amplitude web pages.
Posted Apr 23, 2026 - 12:56 PDT
This incident affected: Data (Web Application), Analytics (Web Application), Audiences (Web Application), Experiment (Web Application), and Guides & Surveys, MCP.