Shared Embeds and Public Links Unavailable

Incident Report for Amplitude

Resolved

This incident is resolved. Shared embeds and public links have been stable since 1:50 AM PT (08:50 UTC), and we have verified affected links render normally. A permanent fix ships later today. No data was lost and no customer action is needed.
Posted Jul 09, 2026 - 02:45 PDT

Monitoring

Between 2026-07-08 5:24 PM PT (00:24 UTC Jul 9) and 2026-07-09 1:50 AM PT (08:50 UTC), shared embeds and public dashboard/chart links displayed blank pages. Customers accessing shared Amplitude content via embed URLs or public links were unable to view charts during this window.

We identified the cause and mitigated by rolling back the affected service. Shared embeds and public links are rendering normally again. No data was lost and no customer action is needed.

We are monitoring stability and will post a final update by 3:00 AM PT (10:00 UTC).
Posted Jul 09, 2026 - 02:12 PDT
This incident affected: Analytics (Web Reporting).