Verification is currently underway for the maintenance items.
Posted Jan 31, 2026 - 09:13 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 31, 2026 - 09:00 PST
Scheduled
We will be performing critical infrastructure maintenance on our US data center during the following time window: Saturday, January 31 at 9:00 AM PT (17:00 UTC).
During these windows, customers may experience a brief blip in connectivity. This will be momentary and services are expected to stabilize immediately after.
Data ingestion and processing will not be impacted, and no action is required from customers.
Posted Jan 26, 2026 - 08:07 PST
This scheduled maintenance affected: Analytics (Web Application).