Login Page Unavailable for New Sign-ins

Incident Report for Amplitude

Resolved

A fix was deployed, and the issue was fully resolved.
Posted Aug 24, 2026 - 20:23 PDT

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 24, 2026 - 20:03 PDT

Investigating

Since 2026-08-24 16:45 PT (23:45 UTC), new sign-ins were unable to load the Amplitude login page (app.amplitude.com/login), which appeared blank. Users with an active session were not signed out and could continue working as normal.
Posted Aug 24, 2026 - 19:06 PDT