Custom Metrics – Metric Details Page Unavailable

Incident Report for Amplitude

Resolved

The incident has been resolved and the Custom Metrics metrics details page displays normally now.
Posted Jul 13, 2026 - 07:59 PDT

Monitoring

A fix has been deployed and the metric details page is loading normally again. We are monitoring error rates to confirm full recovery across all regions before resolving. No data was lost during this incident.
Posted Jul 13, 2026 - 07:32 PDT

Identified

We have identified the root cause and a fix is being deployed. We will post an update as the deployment completes.
Posted Jul 13, 2026 - 07:05 PDT

Investigating

Since 2026-07-12 11:47:42 PM PDT (2026-07-13 07:47:42 AM CET), we have been experiencing issues with the Amplitude user interface (UI). Currently, the Custom Metrics metric details page may fail to load or display an error.

Our team is actively investigating the source of the issue and will work to deploy a fix. We expect no data loss. No customer action is needed at this time.

We will provide the next update by 6:00 AM PDT.
Posted Jul 13, 2026 - 04:41 PDT
This incident affected: Analytics (Web Reporting).