Brief Service Disruption

Incident Report for Amplitude

Resolved

Incident timeline

Resolved — Amplitude is accessible once again, and customers should be able to access the platform as expected.

Posted Aug 25, 2026 - 14:03 PT

Investigating — Since approximately 13:48 PT, some customers may have experienced a brief interruption when using Amplitude.

Posted Aug 25, 2026 - 13:48 PT

We apologize for the disruption.
Posted Aug 25, 2026 - 13:48 PDT