Experiment Creation Unavailable

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 11:09 PDT

Investigating

Components Affected: Experiments

Message:

Since 2026-03-25 10:09 AM PT (17:09 UTC), users have been unable to create new experiments in Amplitude Experiment. Existing experiments and other Experiment functionality are not affected.

Our team has identified the source of the issue and is actively working to deploy a fix. We expect no data loss. No customer action is needed at this time.

We will provide the next update by 12:00 PM PT (19:00 UTC).
Posted Mar 25, 2026 - 11:00 PDT
This incident affected: Experiment (Flag Configurations API).