We are actively investigating bigquery exports taking a long time to complete

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 08:59 PDT

Monitoring

The jobs waiting on google's end have started recovering and we are seeing jobs making progress within Amplitude too
Posted Jul 24, 2026 - 08:15 PDT

Investigating

We are currently investigating this issue.
Posted Jul 24, 2026 - 07:45 PDT
This incident affected: Data (Data Export).