Snowflake Data Share export delivery issue

Incident Report for Amplitude

Update

We continue to work on implementing a fix for the authentication issue affecting Snowflake Data Share delivery. Data Share delivery remains affected. No data loss is expected, and no customer action is needed. Delayed data will be delivered once the issue is resolved.

We will provide another update in 30 minutes.
Posted Sep 22, 2026 - 13:49 PDT

Update

We continue to work on implementing a fix for the authentication issue affecting Snowflake Data Share delivery. Delivery remains affected. No data loss is expected, and no customer action is needed. Delayed data will be delivered once the issue is resolved.

We will provide another update in 30 minutes.
Posted Sep 22, 2026 - 13:19 PDT

Update

Implementation of a fix is in progress. Snowflake Data Share delivery remains affected. No data loss is expected, and no customer action is needed. Delayed data will be delivered once the issue is resolved.

We will provide another update in 30 minutes.
Posted Sep 22, 2026 - 12:50 PDT

Identified

The authentication issue and fix path have been identified; implementation is in progress. No data loss is expected. No customer action is needed.

We will share another update in 30 minutes.
Posted Sep 22, 2026 - 12:19 PDT

Investigating

Starting at 17:00 UTC, new data is not being delivered to Snowflake Data Share destinations. Existing shared data remains available, and data ingestion and analytics in Amplitude are not affected. No data loss is expected.

Our team has identified an authentication issue on our side and is working on a fix. Delayed data will be delivered once resolved. No customer action is needed.

We will share another update in 30 minutes.
Posted Sep 22, 2026 - 11:49 PDT
This incident affects: Data (Data Export).