Historical Data may be temporarily unavailable for customers who use the User Privacy API

Incident Report for Amplitude

Resolved

As of Nov 22, 2025 14:00 UTC, this incident is resolved and customers should be able to see all historical data. Please reach out to support if you're still seeing gaps in your historical data.
Posted Nov 22, 2025 - 09:07 PST

Update

We’ve deployed a fix and started reprocessing historical data. We currently estimate recovery will complete within 24 hours. We’ll provide an update once this is completed or if there are any other changes we need to share. If you have additional questions please reach out to Amplitude Support.
Posted Nov 21, 2025 - 18:09 PST

Identified

Some customers using the User Privacy API recently may see gaps or missing historical data in their charts. This is a display issue only, no underlying data has been lost. Features using cohorts built on top of historical data may also be impacted.

Data ingestion is not impacted.

We have identified the cause and are working on a fix. We are working on getting an estimated ETA.
Posted Nov 21, 2025 - 15:40 PST
This incident affected: Analytics (Web Reporting).