EU data processing delay

Incident Report for Amplitude

Resolved

The fix has been implemented and the issue has been resolved.
Posted Mar 02, 2025 - 12:56 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 02, 2025 - 11:53 PST

Investigating

From 17:30 March 2nd, 2025 UTC, our EU data processing component is slower than usual and all customers are seeing a delay in recent data in their charts, streaming exports, or experiments. As of now, we are not expecting any data loss and further actions are not necessary from our customers.
We are actively working on this issue and will post another update in the next 1 hour.

No impact to the US customers.
Posted Mar 02, 2025 - 11:01 PST
This incident affected: Analytics (Web Reporting) and Data (Data Processing, Cohort Export, Event Streaming, Data Export).