Duplicate Revenue Data
Incident Report for Amplitude
Postmortem

Between June 6th 21:00 UTC and June 7th 17:00 UTC up to half of all revenue data sent client-side to Amplitude was duplicated.

What happened?

On June 6th, we began an infrastructure upgrade on our revenue verification system and introduced an error into the configuration. On June 7th 17:00 UTC our engineering team identified and stopped the duplication. No data was lost during this incident.

Cause

There was a misconfiguration during the infrastructure upgrade.

Next Steps

Our engineering team is currently working on a fix to correct the duplicate events and has implemented to measures to prevent this misconfiguration issue from occurring again. Our initial estimate is that a fix will take at least 2 weeks to deploy.

We sincerely apologize for any inconvenience this has caused. Thanks for your understanding and support.

Resolution

As of Monday June 12, our engineering team has deployed a fix to correct the duplicate events.

Posted Jun 08, 2017 - 18:35 PDT

Resolved
This incident has been resolved.
Posted Jun 08, 2017 - 18:34 PDT
Investigating
We are investigating an issue where we have potentially duplicated processing of revenue data.
Posted Jun 08, 2017 - 18:33 PDT