Data processing delay

Incident Report for Amplitude

Resolved

The issue has been resolved and all pipelines have caught up.
Posted Aug 14, 2025 - 20:10 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2025 - 18:18 PDT

Update

The issue has been mitigated and the pipelines are catching up. The status page will be updated once we are all caught up.
Posted Aug 14, 2025 - 18:18 PDT

Update

We are continuing to investigate this issue.
Posted Aug 14, 2025 - 18:17 PDT

Investigating

We are actively investigating an ingestion delay in data processing in our realtime and our batch pipelines.
Posted Aug 14, 2025 - 17:41 PDT
This incident affected: Data (Data Processing, Event Streaming, Data Export).