Query are slow to load

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 21:00 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 16, 2025 - 20:45 PDT

Identified

From 19:40 PST, Query system is experiencing some issues. It's related to some new user issue, we might disable New User analysis for a while to mitigate the issue to recover faster.
Posted Sep 16, 2025 - 19:59 PDT
This incident affected: Analytics (Web Reporting).