Amplitude website outage on some countries

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Sep 24, 2025 - 12:40 PDT

Monitoring

We didn't find any issues on our system, it could be some underlying Infra issues. We will keep monitor and follow up with our Infra providers.
Posted Sep 24, 2025 - 05:33 PDT

Investigating

Our website is not accessible from some countries transiently, we are investigating the issue
Posted Sep 24, 2025 - 05:15 PDT
This incident affected: Analytics (Web Reporting).