Application Performance Degradation

Incident Report for Amplitude

Resolved

The issue causing elevated application latency has been resolved. We have confirmed that system performance has returned to normal levels and continue to monitor closely to ensure ongoing stability.
Posted May 21, 2026 - 23:32 PDT

Monitoring

We have identified the root cause and implemented a fix. We are currently monitoring the application to ensure performance remains stable and services continue to recover as expected.
Posted May 21, 2026 - 23:06 PDT

Investigating

We are currently investigating elevated application latency affecting portions of the platform. Users may experience slower page loads, delayed query responses, or intermittent timeouts.
Posted May 21, 2026 - 19:51 PDT
This incident affected: Data (Web Application), Analytics (Web Application), Experiment (Web Application), and Guides & Surveys, Session Replay, Heatmaps.