Amplitude UI and MCP is down

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 16:07 PDT

Monitoring

A fix has been implemented, and we're monitoring the results
Posted Jul 13, 2026 - 14:53 PDT

Update

We are continuing to investigate this issue.
Posted Jul 13, 2026 - 14:32 PDT

Investigating

Since 2026-07-13 14:04 PT, we have been experiencing issues with the Amplitude user interface (UI) MCP and rest APIs.


Our team is actively investigating the source of the issue and will work to deploy a fix. We expect no data loss. No customer action is needed at this time.
EU data center should be unaffected by this outage.


We will provide the next update in 30 mins.
Posted Jul 13, 2026 - 14:31 PDT
This incident affected: Analytics (Web Reporting, Web Application), Data (Web Application), Audiences (Web Application), Experiment (Web Application), and MCP.