Data Processing Delay
Incident Report for Amplitude
Resolved
Since 07:05PM PT, 2023-07-27, our realtime data processing has fully recovered. There was no data loss during this incident and no further actions are required from our customers.
Posted Jul 27, 2023 - 19:50 PDT
Monitoring
We deployed a fix at 5:45PM PT and the data processing delay has been recovering since then. We will continue monitoring the recovery.
Posted Jul 27, 2023 - 18:20 PDT
Identified
From 5:10PM PT, 2023-07-27, our data processing pipeline started experiencing a delay up to two hours. We have identified the issue and is working on deploying a fix.

We expect no data loss during this window and further actions are not required from our customers.
Posted Jul 27, 2023 - 17:42 PDT
This incident affected: Data (Data Processing).