Some customers are unable to access certain parts of Amplitude

Incident Report for Amplitude

Resolved

This incident has been resolved.
Posted Mar 05, 2025 - 16:39 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2025 - 16:32 PST

Identified

We have identified the root cause of the issue and have developed a fix. Our team is currently rolling out the fix to all affected customers.
Posted Mar 05, 2025 - 16:17 PST

Investigating

Our team is actively investigating the issue to identify the root cause and restore full access as soon as possible.

We will provide further updates as we learn more. Thank you for your patience.
Posted Mar 05, 2025 - 16:02 PST
This incident affected: Analytics (Web Reporting, Web Application), Data (Web Application), Audiences (Web Application), and Experiment (Web Application).