Data Processing Delays
Incident Report for Amplitude
Resolved
All data is caught up and should now be processed in realtime.
Posted May 19, 2020 - 09:55 PDT
Monitoring
The delay in processing was due to an issue with a dependency of the data processing system. We've identified and fixed the issue, the data processing system is now catching up on the data that is behind.
Posted May 19, 2020 - 08:41 PDT
Investigating
Our data processing systems are delayed. This incident started at 7am.

Current status:
a) Our ingestion systems are working as expected and we are not losing data. Our processing systems are behind on processing newly ingested data.
b) Approx. 10% of data is impacted
c) Customers will see delayed metrics for the last ~2hours

We are investigating the issue and will post an update after 30 minutes or earlier if we identify the issue.
Posted May 19, 2020 - 08:39 PDT
This incident affected: Data Processing.