Data Processing Delays
Incident Report for Amplitude
Resolved
From 13:15 to 16:35 UTC May 19th, 2022, our data processing component was experiencing more than 15 minutes of latency. All of our customers were affected. All of our systems are back to normal with no data loss and they are operating normally. No further action is required by our customers.
Posted May 19, 2022 - 09:46 PDT
Investigating
Our data processing systems are delayed. This incident started at 13:15 UTC.

Current status:
a) Our ingestion systems are working as expected and no data is lost. Our processing systems are not processing newly ingested data.
b) All of our customers are impacted.
c) Impacted customers will see delayed metrics for the last 30 minutes.

We have implemented a fix and are monitoring the situation.
Posted May 19, 2022 - 08:18 PDT
This incident affected: Data (Data Processing).