Web Reporting Intermittent Slow Performance and Errors
Incident Report for Amplitude
Resolved
We have redistributed load and improved some specific queries in order to address the performance issues on the affected database. We believe all issues stemming from this incident should now be resolved.

If you are still experiencing any problem please reach out to our platform team via the help desk.
Posted Apr 13, 2021 - 15:26 PDT
Update
We are continuing to investigate the performance issues and are actively testing some potential improvements.
Posted Apr 13, 2021 - 14:57 PDT
Investigating
The Amplitude website https://analytics.amplitude.com is experiencing issues with poor performance and failures to load data.

We have already identified the source to be a particular database and are working to resolve the underlying problems.
Posted Apr 13, 2021 - 14:04 PDT
This incident affected: Analytics (Web Reporting).