Data Processing Latency (US Site)
Incident Report for Amplitude
Resolved
From 16:30 till 17:52 Oct 16th, 2024 PDT, our US data processing component was slower that usual and all US customers experience up to 87 minutes of latency in their incoming data in their charts, streaming exports, or experiments.
There was no data loss during this incident and further actions are not necessary from our customers.
Posted Oct 16, 2024 - 21:53 PDT
Update
Our realtime pipeline has caught up. We are monitoring the /batch pipeline to catch up for full recovery. ETA is about one hour from now.
Posted Oct 16, 2024 - 20:32 PDT
Monitoring
We have identified the root cause and deployed a fix. We are now monitoring the system to clear the data backlog.
We do not expect to have any data loss during this incident and further actions from our customers are not necessary.
Next update will be in about 2 hours
Posted Oct 16, 2024 - 18:23 PDT
Update
We are continuing to investigate this issue.
Posted Oct 16, 2024 - 17:53 PDT
Investigating
From 16:30 Oct 16th, 2024 PDT, our US data processing component is slower that usual and all customers are missing the last one hour of their incoming data in their charts, straaming exports, or experiments. As of now, we are not expecting any data loss and further actions are not necessary from our customers.
We are actively working on this issue and will post another update in the next 1 hour.
Posted Oct 16, 2024 - 17:51 PDT
This incident affected: Analytics (Web Reporting) and Data (Data Processing, Cohort Export, Event Streaming, Data Export).