data processing delays
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted Jun 26, 2020 - 15:10 PDT
Update
We are now experiencing an uneven recovery due to region specific load. We have taken steps to address this issue, but as a result customers may see their data delayed for an additional hour
Posted Jun 26, 2020 - 14:08 PDT
Investigating
Our data processing systems are delayed due to a hardware failure that previously occurred. We have replaced the hardware but data processing will be delayed for approximately 1 hour as we recover and catch up.
Posted Jun 26, 2020 - 13:08 PDT
This incident affected: Data (Data Processing).