Data Processing delays
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 08, 2019 - 19:09 PDT
Identified
We are experiencing some delays in our data processing systems and data for a few customers is delayed for a maximum of 60 minutes. We have identified and the issue and are working to getting it resolved as soon as possible.

No data is being lost.
Posted 4 months ago. Jul 08, 2019 - 08:18 PDT
This incident affected: Data Processing.