Data Processing Delays
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 27, 2019 - 16:16 PDT
Monitoring
Our data processing is still catching up. The most delayed components are about 60 minutes behind, average delay is about 30 minutes.
Posted 3 months ago. Mar 27, 2019 - 13:08 PDT
Investigating
We are still slowly catching up and would need another few hours to catch up with the delay.
We will update again around 1pm.
Posted 3 months ago. Mar 27, 2019 - 11:14 PDT
Monitoring
The current delay in our processing systems is around 90 minutes. We are already catching up on the lag, but it's taking longer than expected because of peak hour traffic. We are scaling our systems to be able to catch up faster.

Our ingestion systems are working as expected and we are not losing any data.
Posted 3 months ago. Mar 27, 2019 - 07:30 PDT
Update
The current delay in our processing systems is 120 minutes. We have fixed the issue and are on our path to recovery. We expect the systems to catch up completely in the next 90-120 minutes. We will update if the timeline changes.

Our ingestions systems are working as expected and we are not losing data.
Posted 3 months ago. Mar 27, 2019 - 06:10 PDT
Identified
Our data processing systems are delayed by around 60 minutes. This incident started at 10:55:00 am UTC.

Current status:
a) Our ingestion systems are working as expected and we are not losing data. Our processing systems are not processing newly ingested data.
b) Impacted customers will see delayed metrics for the last 60 minutes.

We have identified the issue and our team is working on fixing it.
Posted 3 months ago. Mar 27, 2019 - 04:58 PDT
This incident affected: Data Processing.