Amplitude corp site temporarily down
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted about 1 year ago. Jul 25, 2018 - 03:13 PDT
Investigating
We are investigating time-out errors when accessing https://amplitude.com/. Access to our analytics services is not affected.
Posted about 1 year ago. Jul 25, 2018 - 02:37 PDT
This incident affected: Web Reporting.