New orgs can't be created in Amplitude
Incident Report for Amplitude
Resolved
This incident has been resolved. Customers can now create new orgs as usual. No data was lost during the incident.
Posted Oct 04, 2023 - 17:19 PDT
Update
We are continuing to investigate the issue and will share another update in an hour.

Existing orgs are not affected by this issue and no data that's sent or being sent to Amplitude is lost.
Posted Oct 04, 2023 - 16:28 PDT
Update
We are continuing to investigate the issue and will share another update in 60 minutes.

Existing orgs are not affected by this issue and no data that's sent or being sent to Amplitude is lost.
Posted Oct 04, 2023 - 15:11 PDT
Investigating
We are currently investigating an issue where users signing up to Amplitude for the first time can't create a new org. We are investigating this issue and will share updates here every 60 minutes.

If you are an existing customer and have an org with Amplitude, you are not affected by this issue. No data is lost.
Posted Oct 04, 2023 - 13:36 PDT