Degraded query performance
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted Oct 22, 2021 - 11:45 PDT
Monitoring
We’ve identified the issue and deployed a fix. We are currently monitoring the results.
Posted Oct 22, 2021 - 07:50 PDT
Identified
We identified the root cause, applying a fix.
Posted Oct 22, 2021 - 06:33 PDT
Investigating
Our query systems are experiencing issues causing slow query response times.
The issue started around 5:10 AM PST on Oct 22nd.

a) Our ingestion systems are working as expected and we are not losing any data.
b) Some queries are experiencing slowness.
c) Impacted customers will experience slow loading times or errors when running reports on Amplitude.

We are investigating the issue and will post an update after 30 minutes or earlier if we identify the issue.
Posted Oct 22, 2021 - 05:58 PDT
This incident affected: Analytics (Web Reporting).