Amplitude Website Slowness
Incident Report for Amplitude
Resolved
This incident has been resolved since 5:00pm PT. The root cause was a scheduled scale-down of a dependent system. We reverted the scale-down to restore query performance.

No data was lost and no further action is required from our customers.
Posted Jul 18, 2023 - 17:30 PDT
Monitoring
Our query engine is having degraded performance. This issue started at 4:30pm PT. All customers might be experiencing slow-loading or timed out charts/cohorts. We identified the root cause and already deployed a fix at 5:00pm PT. The query engine's performance recovered since then. We will keep monitoring the performance for another 10 minutes.
Posted Jul 18, 2023 - 17:07 PDT
This incident affected: Analytics (Web Reporting).