Creating new cohorts and editing existing cohorts is partially broken
Incident Report for Amplitude
Resolved
The incident has been resolved. Creating new cohorts and editing existing cohorts is operating as expected.

No data was lost during the course of the incident.
Posted Aug 22, 2023 - 06:52 PDT
Identified
Customers aren't able to edit existing cohorts and create new cohorts using the "Define my own" option in the Create Cohort workflow. Customers also aren't able to edit a copy of an existing cohort. We have identified the issue and are working on a fix for it.
Posted Aug 22, 2023 - 06:20 PDT