Data Processing Delays
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted May 19, 2022 - 22:53 PDT
Update
From 23:15 PM UTC May 19 till 5:30 AM May 20, 2022, all customers using our data processing component was experiencing up to one and half hours of latency. All of our systems are back to normal with no data loss and they are operating normally. No further action is required by our customers.
Posted May 19, 2022 - 22:52 PDT
Update
We have found the root cause and applied the fix. We are now monitoring the system. Some of our customers have experienced up to 1.5 hours of latency in our data processing component. We expect no data loss. We will verify possible data loss again when the system is completely back to its normal state again.
Posted May 19, 2022 - 20:43 PDT
Update
We are continuing to monitor for any further issues. Impacted customers will see delayed metrics for the last 35 minutes
Posted May 19, 2022 - 18:38 PDT
Monitoring
Our data processing systems are delayed. This incident started at 23:15 PM UTC.

Current status:
a) Our ingestion systems are working as expected and no data is lost. Our processing systems are not processing newly ingested data.
b) All of our customers are impacted.
c) Impacted customers will see delayed metrics for the last 60 minutes.

We have implemented a fix and are monitoring the situation.
Posted May 19, 2022 - 17:18 PDT
This incident affected: Data (Data Processing).