Data Processing Delays
Incident Report for Amplitude
Resolved
Our data processing systems have completely caught up. No data was lost during the incident and no further action is required from our customers.
Posted Nov 10, 2020 - 19:41 PST
Monitoring
Data processing is mostly caught up with realtime data(sdk, httpapi), some batch data (/batch, vacuum) is delayed by up to 200min.
Posted Nov 10, 2020 - 19:22 PST
Identified
Our data processing systems are delayed because of instance availability issues. This incident started at 3PM PST.

Current status:
a) Our ingestion systems are working as expected and we are not losing data. Our processing systems are not processing some of the newly ingested data.
b) All of our customers are impacted.
c) Some of the realtime data (sdk, httpapi) is delayed by upto 60min and some batch data (/batch, vacuum) is delayed by upto 150min. Impacted customers will see delayed metrics for the last 1 - 2.5 hours.

Will post an update in an hour or earlier.
Posted Nov 10, 2020 - 17:39 PST
This incident affected: Data Processing.