The migration is complete, and all systems should now be fully operational. We will continue to verify and monitor throughout the remainder of the maintenance window.
Posted Jul 26, 2025 - 14:56 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 26, 2025 - 14:00 PDT
Scheduled
We will be conducting maintenance on a shared component of the Amplitude product in our EU data center on July 26th, between 9:00 PM and 11:00 PM UTC.
During this maintenance window, some temporary service interruptions may occur. Ingestion processor will be paused to minimize risks so there will be data processing delays. No data loss is expected during or after the maintenance period.
Customers in the US region will not be affected.
Posted Jul 22, 2025 - 20:45 PDT
This scheduled maintenance affected: Analytics (Web Reporting, Web Application), Experiment (Evaluation API, Management API, Web Application), Data (Web Application, Data Processing, Cohort Export, Event Streaming), and Guides & Surveys, Marketing Website, Session Replay, Heatmaps.