data missing from the /batch endpoint We are replaying events from Vacuum, mParticle, Segment, Braze, and RudderStack
Incident Report for Amplitude
Resolved
All the replays are complete. However, there might be some missing data in your charts because of our data loss incident. Please let us know about those and we will provide any support needed.
You can read about what has happened in this post mortem [WIP]: https://status.amplitude.com/incidents/y10hzwnc4j0k
Posted Jul 27, 2021 - 11:03 PDT
Update
Here is the current status:
Replays are finished: Vacuum, mParticle, Braze, and RudderStack
Replays in progress: Segment.
Posted Jul 27, 2021 - 00:20 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 23, 2021 - 00:11 PDT
Update
RudderStack has replayed their data. Customers using RudderStack service should see all their data in their charts.
Posted Jul 22, 2021 - 23:16 PDT
Update
In addition to mParticle and Segment, we are engaging with Braze and RudderStack to replay their data.
Posted Jul 22, 2021 - 11:37 PDT
Monitoring
We have replayed Vacuum data. Customers who have used our Vacuum service should see all their data in their charts.
Posted Jul 21, 2021 - 17:52 PDT
Identified
During the data processing incident on 7/20/2021 12:22 PM PDT, we encountered a data ingestion issue from our /batch API from 7/20/2021 11:45 AM PDT to 7/21/2021 2:20 AM PDT. We are replaying data from our Vacuum system, and from our partners: mParticle, and Segment. Customers who send us data using one of the above methods do not need to take any action. Customers who are using our /batch API directly may send us the data again to fill the data gap.
Posted Jul 21, 2021 - 10:26 PDT
This incident affected: Data (Data Processing).