Amplitude is double counting events for some projects
Incident Report for Amplitude
Resolved
All results should be correct now. Please reach out if you still see incorrect results.
Posted Oct 06, 2023 - 15:30 PDT
Update
We finished invalidated cache on incorrect data. You should be able to see correct results now without any actions.
Posted Oct 06, 2023 - 15:28 PDT
Monitoring
All data has been reprocessed and we expect all charts to be correct now. Please refresh your charts if you still see higher event count.
Posted Oct 06, 2023 - 14:03 PDT
Update
We are reprocessing the data for the impacted customers and expect another 1 hour for most of impacted customers to recover.
Posted Oct 06, 2023 - 13:02 PDT
Identified
We introduced a bug in our indexing system at Oct 4, 2023 7:35 PM PST, which caused a corner case to double count events for 270 projects that have some special configs.

We are rolling back our index system and reprocess the data in the last 2 days. We expect the system to be fully recovered in a couple hours, at which point all double-counted events will be corrected.
Posted Oct 06, 2023 - 12:23 PDT
This incident affected: Analytics (Web Reporting).