Amplitude queries are slow or not loading
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted Feb 20, 2024 - 14:43 PST
Monitoring
The system should be back now, we will keep monitoring for a while to make sure it works well.
Posted Feb 20, 2024 - 14:25 PST
Investigating
We deployed a bad bug causing query being slow or not stable. We are in the progress of rolling back, will update soon.
Posted Feb 20, 2024 - 14:09 PST