Realtime Data Pipeline Delay

Incident Report for Amplitude

Resolved

From approximately 11:30 AM PDT (18:30 UTC) to 2:14 PM PDT (21:14 UTC), Amplitude experienced delays affecting the realtime data pipeline. Some data may have been delayed before appearing in Amplitude in real time.

The issue has been resolved. There is no data loss, and no customer action is needed.
Posted Sep 17, 2026 - 14:15 PDT

Update

We are continuing to monitor the system to confirm full recovery. There is no data loss, and no customer action is needed.

We will provide the next update in 30 minutes.
Posted Sep 17, 2026 - 14:05 PDT

Monitoring

Recovery is underway, and we are monitoring the system to confirm full recovery. There is no data loss, and no customer action is needed.

We will provide the next update in 30 minutes.
Posted Sep 17, 2026 - 13:34 PDT

Update

We are continuing to investigate this issue.
Posted Sep 17, 2026 - 13:05 PDT

Investigating

Since 11:30 AM PST, Amplitude has been experiencing a
realtime data pipeline delay. Some data may not yet
appear in Amplitude in real time and may be delayed before it can be
streamed or exported to downstream destinations.

Our team is actively investigating the source of the issue and working to
deploy a fix. There is no data loss. No customer action is needed
at this time.

We will provide the next update in 30 minutes.
Posted Sep 17, 2026 - 13:05 PDT
This incident affected: Data (Data Processing).