Data processing is experiencing delays
Incident Report for Amplitude
Resolved
The system has recovered. Data processing is fully operational. Realtime data is available for all queries. No data was lost during this time.
Posted 12 months ago. Sep 20, 2018 - 17:31 PDT
Monitoring
We have deployed a fix to the dependency that's having the performance issue.
Delayed components are catching up quickly across the entire clusters. We are actively monitoring the improvement.
Currently, the delay is up to 100 minutes.
Data collection is working as expected and we are not losing data.
Posted 12 months ago. Sep 20, 2018 - 15:04 PDT
Identified
The issue which is causing delays has been identified. We are actively looking for solutions to improve the efficiency of this dependency. Currently, the delay is around 50 minutes.

Data collection is working as expected and we are not losing data.
Posted 12 months ago. Sep 20, 2018 - 10:38 PDT
Investigating
Our data processing infrastructure is currently in a degraded state due to a load issue on a dependency. Data processing is currently delayed by up to 30 minutes.

Data collection is working as expected and we are not losing data.
Posted 12 months ago. Sep 20, 2018 - 07:34 PDT
This incident affected: Data Processing.