Web Reporting Intermittent Slow Performance and Errors
Incident Report for Amplitude
Resolved
Service should now have returned to normal.

We are continuing to monitor system performance and are implementing more significant improvements to prevent this issue from re-occurring.
Posted Apr 14, 2021 - 14:40 PDT
Identified
The Amplitude website https://analytics.amplitude.com is experiencing issues with poor performance and failures to load data.

We are in the process of spinning up additional resources to help relieve the load experienced on one of our databases.
Posted Apr 14, 2021 - 10:22 PDT
This incident affected: Web Reporting.