Amplitude Website is Down
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted 19 days ago. Oct 03, 2019 - 07:26 PDT
Monitoring
Fix has been made and the website has recovered
Posted 19 days ago. Oct 03, 2019 - 07:25 PDT
Investigating
We are currently having server hardware issues with several of our servers. This is causing problems loading the website. We are working on the fix.
Posted 19 days ago. Oct 03, 2019 - 07:13 PDT
This incident affected: Web Reporting.