Data Processing Delays (Batch Endpoint)
Incident Report for Amplitude
Resolved
This incident has been resolved.
Posted Sep 07, 2021 - 12:49 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 07, 2021 - 09:22 PDT
Identified
Our data processing systems are delayed for about 5% of data coming through the batch endpoint. This incident started at 12:15 UTC.

Current status:
a) Our ingestion systems are working as expected and no data is lost. Our processing systems are not processing newly ingested data.
b) About 5% of data coming through the batch endpoint (including S3 ingestion) is impacted.
c) Impacted customers will see delayed metrics for the last 3 hours.

We are investigating the issue and will post an update in an hour or earlier if we identify the issue.
Posted Sep 07, 2021 - 08:09 PDT
This incident affected: Data (Data Processing).